OpenWRT (kamikaze) with x-wrt on Fonera!

Decided to toy with OpenWRT kamikaze on the FON. Noticed that there is x-wrt for for it! So swapped out my dd-wrt on FON and put in the latest build of OpenWRT kamikaze!

First thing to do after placing the OpenWRT in? SSH back into the device and start editing the necessary configuration files.

root@OpenWrt: ~# vi /etc/config/firewall

add in the following 2 entries at the end of the file

accept:proto=tcp dport=22
accept:dport=80

Then edit the configuration file for network setting

root@OpenWrt: ~# vi /etc/config/network

mine looks like this

# Copyright (C) 2006 OpenWrt.org

config interface loopback
option ifname lo
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0

config interface lan
option type bridge
option ifname eth0
option proto dhcp
option hostname Fonera

save the file and then reboot the device!

This time hook it up to your main router so that it connects with the internet.

Now SSH into the router after it has rebooted (through the dhcp-ed address) and then issue the command

root@OpenWrt: ~# ipkg install http://downloads.x-wrt.org/xwrt/kamikaze/atheros-2.6/webif_latest.ipk

On the next reboot, you will have webif! Have fun with OpenWRT on FON.

Regularly check out if there are newer builds of x-wrt. You can force install it by

root@OpenWrt: ~# ipkg install http://downloads.x-wrt.org/xwrt/kamikaze/atheros-2.6/webif_latest.ipk -force-reinstall

foneraOpenWRT01small.gif

foneraOpenWRT02small.gif

foneraOpenWRT03small.gif

 

Treat shadowandy!

If these step-by-step guides have been very helpful to you and saved you a lot of time, please consider treating shadowandy to a cup of Starbucks.  

2 thoughts on “OpenWRT (kamikaze) with x-wrt on Fonera!

  • February 23, 2007 at 2:33 am
    Permalink

    Flashing your FON to OpenWRT

    Yes! It’s OpenWRT (kamikaze). Since it doesn’t come with webif (web interface) at the moment hence you will need to do all configuration through SSH. <caution>It is not for the faint hearted.</caution> Preparation Steps * You must be able t…

  • May 14, 2007 at 3:29 pm
    Permalink

    OpenWRT Kamikaze Builds for Atheros

    This entry contains archives of firmwares specifically for Atheros devices. They have been compiled and mostly tested by me. Don’t hold me responsible if it breaks your device. Do take note that you would need to install the webif and…

Comments are closed.